Community
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Using TextPad as default editor correctly

 
Post new topic   Reply to topic    Community Forum Index -> Tips
View previous topic :: View next topic  
Author Message
Janus



Joined: 23 May 2004
Posts: 1

PostPosted: Sun May 23, 2004 2:43 pm    Post subject: Using TextPad as default editor correctly Reply with quote

! I use german version of my operating system, so certain names may differ from my translation !

Operating System I use: Windows XP (no idea whether this is the same on others)

Symptome: When TextPad is set as default editor for a specific type of file and one opens multiple files at the same time, windows will create a new instance of TextPad for each file.

Reason: The DDE execution command is not set correctly.

Solution: Go to the screen to edit file types (explorer->extras->folder options->file types) and hit the advanced options button after selecting the file type we want to open with TextPad.
Now hit the edit button and you get a new window showing 6 edit fields:

edit
"DRIVE:\FOLDER\TextPad.exe" %1
<EMPTY>
TextPad
<EMPTY>
System

now change it to

edit
"DRIVE:\FOLDER\TextPad.exe" %1
[open("%1")]
TextPad
<EMPTY>
System


Now you can open multiple files with your default editor: TextPad.

Sorry for bad grammar and stuff...
Back to top
View user's profile Send private message
chatt



Joined: 28 Aug 2003
Posts: 23
Location: near Toronto

PostPosted: Thu May 05, 2005 12:27 am    Post subject: Re: Using TextPad as default editor correctly Reply with quote

I'm using XP Pro with SP 2 and suspect that's a problem.

I've been using TP for years from Explorer, except for lately.
I applied the below fix (DDE = [open("%1")] ) and now can open a file with right click->Open but nothing else -- it just sits there.

So what do I do next?

Thanks,
Peter.


Janus wrote:
! I use german version of my operating system, so certain names may differ from my translation !

Operating System I use: Windows XP (no idea whether this is the same on others)

Symptome: When TextPad is set as default editor for a specific type of file and one opens multiple files at the same time, windows will create a new instance of TextPad for each file.

Reason: The DDE execution command is not set correctly.

Solution: Go to the screen to edit file types (explorer->extras->folder options->file types) and hit the advanced options button after selecting the file type we want to open with TextPad.
Now hit the edit button and you get a new window showing 6 edit fields:

edit
"DRIVE:\FOLDER\TextPad.exe" %1
<EMPTY>
TextPad
<EMPTY>
System

now change it to

edit
"DRIVE:\FOLDER\TextPad.exe" %1
[open("%1")]
TextPad
<EMPTY>
System


Now you can open multiple files with your default editor: TextPad.

Sorry for bad grammar and stuff...
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Community Forum Index -> Tips All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB