TextPad Szukaj    Kontakt    Strona główna   
Pomoc
Uwagi  |  FAQ  |  Porady  |  Informacje o wersji   |  Lista dyskusyjna  |  Forum 

 

Ostatnia aktualizacja: 10 października, 2001

W większości cytowane porady pochodzą od naszych użytkowników. Jeżeli chciałbyś się z nami podzielić swoimi doświadczeniami prześlij je do support@textpad.com.


Jak wprowadzać pliki wsadowe SQL do MySQL poleceniem w menu Narzędzia

Używanie MySQL za pomocą TextPada.

Podziękowania dla pomocy technicznej TextPada z wskazówkę: Uruchom mysql z pliku .BAT

Ustawienia:

1. Napisz plik wsadowy (mysql.bat) zawierający linię:
     mysql -vvv < %1
			Wstaw go gdziekolwiek w PATH - ja używam C:\
		
2. W Textpad:Konfiguracja:Preferencje:Narzędzia:Dodaj...
			Polecenie: c:\mysql.bat
			Parametry: $File
			Rozpocznij w: $FileDir
			Wyświetl rezultat włączony

3. Napisz plik sql, w pierwszym wierszu podając bazę danych, której chcesz użyć.
(In another_trial.sql)

			use test;

			create table noch_try(
			jnum int,
			jwrd varchar(50)
			);

			show tables;
4. Uruchom narzędzie

5. Wynik:

			--------------
			create table noch_try(
			jnum int,
			jwrd varchar(50)
			)
			--------------

			Query OK, 0 rows affected (0.00 sec)

			--------------
			show tables
			--------------

			+-----------------+
			| Tables_in_test  |
			+-----------------+
			| event           |
			| imptest         |
			| noch_try        |
			| pet             |
			+-----------------+
			4 rows in set (0.00 sec)

		
Oczywiście później po wprowadzeniu zmian do tablicy, musisz wpisać drop table lub coś podobnego przed poleceniem CREATE.

Wpisywanie danych do tablic MySQL z TextPada
Use:
mysqlimport [options] database textfile1

[Część 14.6 w mySQL Manual podaje możliwe opcje]

Konfiguracja dla importu do mySQL TextPad:Konfiguracja:Preferencje:Narzędzia:Dodaj...

				Polecenie: C:\mysql\bin\mysqlimport.exe
				Parametry: --local --fields-terminated-by=^ -v database $File
				Katalog: $FileDir
				Włącz Pytaj o parametry, aby wpisywać 'bazę danych', której będziesz używał za każdym razem..
		
Nadaj plikowi tę samą nazwę co tablica, do której chcesz wpisać dane:

Przykładowa sesja;
1. Utwórz tablice test w mySQL:

				mysql> use test; -- To baza danych, w której utworzę tablicę
				Database changed
				mysql> create table try_it(num int, wrd varchar(50));
				Query OK, 0 rows affected (0.00 sec) -- that's the table made.

2. Uwórz dane wejściowe w TextPadzie i zapisz (w formacie UNIX) z taką samą nazwą jak tablica (Tutaj try_it.txt)
				1^Pierwszy wpis^
				2^Drugi wpis^
				3^Separator, którego używam rzadko spotyka się w tekście^
				4^Stosuje go także na końcu^
				5^Oznacza koniec komórki^
				6^Ułatwia wstawianie danych do tablic^
				7^Pamiętaj o zapisaniu w formacie UNIX^
				8^Konieczne dla prawidłowego zakończenia rekordu^
				9^Dość przydatne^

3. Uruchom narzędzie z TextPada (Wpisz bazę danych do testowania).
				Connecting to localhost
				Selecting database test
				Loading data from LOCAL file: C:/Windows/DESKTOP/try_it.txt into try_it
				test.try_it: Records: 9  Deleted: 0  Skipped: 0  Warnings: 9
				Disconnecting from localhost
				Process completed successfully

4. Sprawdź tablicę w mySQL:
        mysql> select * from try_it;
				+------+======================================-------+
				| num  | wrd                                         |
				+------+======================================-------+
				|    1 | Pierwszy wpis                       |
				|    2 | Drugi wpis                              |
				|    3 | Separator, którego używam rzadko spotyka się w tekście         |
				|    4 | Stosuje go także na końcu |
				|    5 | Oznacza koniec komórki.          |
				|    6 | Ułatwia wstawianie danych do tablic    |
				|    7 | Pamiętaj o zapisaniu w formacie UNIX       |
				|    8 | Konieczne dla prawidłowego zakończenia rekordu           |
				|    9 | Dość przydatne                              |
				+------+======================================-------+
				9 rows in set (0.00 sec)

		

Przesłał: John Montgomery


Jak skonfigurować Ctags jako narzędzie TextPada.

Ctags może wygenerować tablicę indeksów i wysłać ją do okna rezultatu polecenia TextPada. Ctag można pobrać z:
http://darren.hiebert.com/ctags/

Skonfiguruj narzędzie DOS z następującymi ustawieniami:

Parametry: ctags -x -R | grep "^$Sel\>"

Wyrażenie regularne: ^[[:alnum:]_]+ +[a-z ]+\([0-9]+\) +\([^ ]+\)

Rejestr pliku = 2
Rejestr wiersza = 1

Ustaw katalog początkowy, tak aby wskazywał na najwyższy element w drzewie plików źródłowych, które chcesz przeszukać.

Uwaga: aby to się udało zarówno ctags jak grep muszą być podane w zmiennej środowiskowej PATH Stosujemy "grep" dostępny po instalacji narzędzi cygwin. Można pobrać http://sources.redhat.com/cygwin/ (można także użyć narzędzi MKS.) Program Ctags obsługuje formaty C, C++, PERL, Java, Fortran i wiele innych.

Aby uruchomić zaznacz słowo kluczowe, które ma być wyszukane, wywołaj narzędzie i kliknij podwójnie wiersz wyniku w oknie rezultatu polecenia.

Przesłał: David Vanden Heuvel, Software Designer, Zucotto Systems, Inc.


Jak używać Ctags by przechodzić do definicji identyfikatorów.

1. Pobierz "Exuberant Ctags", aby utworzyć plik ctags. Dostępny na stronie: http://ctags.sourceforge.net/
2. Utwórz plik ctags dla swego oprogramowania. Zastosuj przełącznik -n, aby plik zawierał numery wierszy.
3. Skompiluj program C++ podany na końcu wiadomości pocztowej. Jeżeli potrzebujesz kompilatora, znajdziesz bezpłatny DJGPP na stronie: http://www.delorie.com/djgpp/
4. Utwórz element menu Narzędzia dla programu:
				Polecenie: <podaj nazwę programu C++>
				Parametry: <ctags file name> $SelWord
				Rozpocznij w: $FileDir
				Opcje włączone: Wyświetl rezultat oraz Powstrzymaj wyprowadzanie rezultatu aż do ukończenia operacji
				Wyrażenie regularne: ^.*, (.*), ([0-9]+)
				Plik: 1
				Wiersz: 2
		
5. Możesz teraz ustawić kursor na identyfikatorze i uruchomić narzędzie. Po pojawieniu się Okna rezultatu kliknij podwójnie element, do którego chcesz przejść.

Uwagi:
1. Metoda zakłada, że kod i plik ctags znajdują się w tym samym katalogu. Jeżeli tak nie jest konieczne będą modyfikacje.
2. Stosuję wyrażenia regularne w standardzie POSIX. Jeżeli Ty go nie używasz, nie zapomnij poprzedzić nawias otwierający i zamykający ukośnikiem wstecznym.

Program C++ do zapisania pliku ctags:

		// C++ program to dump ever occurrance of a given tag in a tag file
		// Usage: <prog> <tag file> <tag>

		#include <string>
		#include <iostream>
		#include <fstream>
		#include <cstring>
		#include <cctype>

		using namespace std;

		int main(int argc, char* argv[])
		{
			// check for correct number of arguments
			if (argc != 3)
			{
				// strip path from progam name
				const char* prg = argv[0];
				const char* const fslash = strrchr(prg, '/');
				const char* const bslash = strrchr(prg, '\\');
				if (fslash && bslash)
					prg = fslash > bslash ? fslash + 1 : bslash + 1;
				else if (fslash)
					prg = fslash + 1;
				else if (bslash)
					prg = bslash + 1;

				cerr << "Usage: " << prg << " <tag file> <tag>" << endl;
				return -1;
			}

			ifstream f(argv[1]);
			if (!f)
			{
				cerr << "Failed to open file." << endl;
				return -1;
			}

			string tag(argv[2]), ftag, file, type, tmp;
			unsigned line;
			while (f && !f.eof())
			{
				f >> ftag;

				if (ftag == tag)
				{
					f >> file >> line;

					getline(f, tmp); // get remainer of line

					// look for type infomation
					type = "";
					int pos = tmp.find(";\"");
					if (pos >= 0)
					{
						// skip whitespace
						pos += 2;
						while (isspace(tmp[pos]))
							++pos;

						type = string(", ") + tmp.substr(pos);
					}

					cout << ftag << ", " << file << ", " << line << type << endl;
				}
				else
					getline(f, tmp); // disgard line
			}

			return 0;
		}
		

Przesłał: Rich Herrick, Lockheed-Martin Federal Systems, Owego, NY


TextPad doskonale nadaje się do edycji kodu VBScript.

Pliki VBScript (*.vbs) możesz uruchamiać z TextPada tworząc nowe narzędzie.

1. W menu Konfiguracja wybierz Preferencje
2. Wybierz stronę Narzędzia, po czym.....

Dodaj "Explorer.exe" z parametrami $FIle i $FileDir.

LUB

Dodaj "cmd" z parametrami $FIle i $FileDir. Użytkownicy Windows NT/2000. Użytkownicy Win 9x powinni użyć "command".

Jeżeli masz zainstalowanego hosta skryptów (MS Scripting Host - WSH), bez problemów uruchomisz VBScript z TextPada.

Przesłał: Peter Gomis, Senior Developer, Skandia AFS IT - Global Systems Engineering Services, Shelton, CT


Ustawienia użytkownika narzędzi pozwalające na wprowadzanie zmian do magazynu CVS.

Wszystkie podane przykłady zakładają, iż na Twoim komputerze zainstalowany jest klient dosowy i że moduł, nad którym pracujesz jest wypisany (checked out). Program WinCVS zawiera program klientów dosowych. Definicje tu podane nie mają zastąpić WinCVS lub DOS CVS, a jedynie ułatwić wpisywanie zmian z TextPada.

CVS Login

		Polecenie: drive:\path\to\cvs\cvs.exe
		Parametry: -z9 -d :pserver:user@host:/path/to/cvs/repository login
		Rozpocznij w: $FileDir
		

Nie przejmuj rezultatu tego polecenia - polecenie wymaga reakcji użytkownika: podania hasła.

CVS Update

		Polecenie: drive:\path\to\cvs\cvs.exe
		Parametry: -z9 update
		Rozpocznij w: $FileDir
		

CVS Commit File

		Polecenie: drive:\path\to\cvs\cvs.exe
		Parametry: -z9 commit -m "" $FileName
		Rozpocznij w: $FileDir
		

Konieczne jest podanie parametrów i wstawienie komunikatu logowania w cudzysłowie.

Przesłał: Dave Weiner - Chief Technology Officer, WebMasters, Inc. - www.webmast.com


Automatyzacja procesu instalacji

Postępując zgodnie z poniższymi instrukcjami, możesz utworzyć instalację standardową do uruchamiania na każdym komputerze bez potrzeby interakcji z użytkownikiem.

Zapisz plik zawierający twe opcje instalacyjne:

  1. Otwórz samorozpakowujący plik (np. TXPENG41.EXE) programem obsługującym format ZIP (np. WinZip).
  2. Rozpakuj wszystkie pliki do folderu na serwerze, zachowując strukturę katalogów.
  3. Naciśnij Start i Uruchom setup z podfolderu DISK1 używając polecenia:
    SETUP.EXE -r
  4. Dokonaj typowej instalacji, wybierając opcje, których potrzebujesz.
  5. Spowoduje to zapisanie twoich wymagań w pliku SETUP.ISS w katalogu Windows. Przenieś SETUP.ISS do podfolderu DISK1.

Po czym skonfiguruj TextPad zgodnie ze swoimi oczekiwaniami w następujący sposób:

  1. Uruchom TEXTPAD.EXE
  2. W menu Pomoc wybierz "Wpisz kod licencji".
  3. Wprowadź kod licencji i kliknij OK.
  4. Wybierz Preferencje z menu Konfiguracja.
  5. Dokonaj potrzebnych zmian na każdej stronie okna dialogowego Preferencje
  6. Wyjdź z programu.

Teraz wydostań ustawienia TextPada z rejestru:

  1. Kliknij Start i uruchom REGEDIT.EXE
  2. Przy pomocy polecenia Export w menu Plik, wyeksportuj do HKCU.REG następujący klucz:
    HKEY_CURRENT_USER\Software\Helios\TextPad 4
  3. Wyeksportuj do HKLM.REG:
    HKEY_LOCAL_MACHINE\Software\Helios\TextPad 4
  4. Uruchom TextPad i otwórz HKCU.REG oraz HKLM.REG.
  5. Utwórz nowy dokument i przekopiuj do niego zawartość HKLM.REG.
  6. Dodaj HKCU.REG bez pierwszej linii ("REGEDIT4").
  7. Zapisz go jako "TEXTPAD.REG" w podfolderze DISK2.

Potem zainstaluj TextPad na każdym komputerze, klikając na start i uruchamiając setup z podfolderu DISK1 na serwerze:

SETUP.EXE -s


Jak uruchamiać programy Javy z automatycznym zamykaniem okna MSDOS.

Dotyczy programu TextPad 4.1, działającego w Windows 98.
Bezpośrednio po instalacji, polecenie "Narzędzia|Uruchom aplikację Javy" nie zamyka okna MSDOS automatycznie po zamknięciu aplikacji.

Aby dodać do menu Narzędzie takie polecenie, postępuj wg poniższych instrukcji:

  1. Wybierz polecenie "Konfiguracja|Preferencje".
  2. Kliknij na Narzędzia w liście po lewej stronie okna Preferencje.
  3. Kliknij przycisk Dodaj i wybierz polecenie "Program...".
  4. W polu "Nazwa pliku" wpisz: c:\windows\command.com i wciśnij Enter.
  5. Dwukrotnie kliknij na tekst "Polecenie" i zmień go na: Szybkie uruchamianie Javy.
  6. Kliknij przycisk "OK".
  7. Wybierz polecenie "Konfiguracja|Preferencje".
  8. Kliknij podwójnie na Narzędzia w liście po lewej stronie okna Preferencje.
  9. Kliknij "Szybkie uruchamianie Javy" na liście po lewej stronie okna "Preferencje".
  10. W polu Parametry wpisz: /C java.exe $BaseName
  11. Usuń zaznaczenie w polu "Przechwyć rezultat".
  12. Kliknij przycisk "OK".

Od teraz kiedy wybierzesz to polecenie by uruchomić program Javy, zamknięcie programu Javy automatycznie spowoduje zamknięcie okna MSDOS. Niestety tracone są dane przesyłane do konsoli MSDOS. Jeżeli chcesz je zachować, zastąp krok 11 podany wyżej:

(alternatywa)
11. Zaznacz zarówno "Przechwyć rezultat" jak i "Powstrzymaj wyprowadzanie rezultatu aż do ukończenia operacji".

Przesłał: Jim Burton


Stosowanie z MS Visual SourceSafe 5:

Aby wpisać i wypisać aktywny plik do Visual SourceSave, możesz dodać polecenia uruchamiające SS.EXE do menu Narzędzia TextPada. Najpierw musisz dodać poniższe wiersze do SS.INI (znajduje się w katalogu z twoją nazwą użytkownika w katalogu \VSS\USERS):
			Comment_Editor_Prompt = Yes
			Comment_Editor = notepad.exe
		
Nie używaj TextPada do edycji komentarzy, ponieważ SourceSafe czeka na jego zamknięcie przed realizacją polecenia.

Aby uruchamiać polecenia w trybie DOS, wpisz:

			C:\VSS\win32\ss.exe checkin nazwa_pliku
			C:\VSS\win32\ss.exe checkout nazwa_pliku
		
Równoważne polecenia można dodać do menu Narzędzia TextPada w następujący sposób:
  1. Wybierz Preferencje z menu Konfiguracja.
  2. Wybierz "Narzędzia" w oknie dialogowym Preferencje.
  3. Kliknij Dodaj i wybierz "Program".
  4. Znajdź SS.EXE przy użyciu okna dialogowego Wybierz plik, i kliknij Otwórz.
  5. Kliknij Zastosuj.
  6. Kliknij "+" obok Narzędzia i wybierz "SS".
  7. Zmień Tekst menu na Check In.
  8. Ustaw Parametry na checkin $FileName
  9. Wpisz do pola Rozpocznij w $FileDir.
  10. Wyczyść wszystkie pola wyboru oprócz Przechwyć rezultat (opcjonalne).
  11. Kliknij Zastosuj.
Powtórz powyższe kroki dla polecenia "checkout".


Publikacja dokumentu przy użyciu WS_FTP:

Aby opublikować bieżący dokument na swojej stronie internetowej przy użyciu WS_FTP, dodaj polecenie do menu Narzędzia TextPada:

		Polecenie: C:\Program Files\WS_FTP\WS_FTP95.EXE
		Parametry: -p My-Profile-Name -s local:$FileName
			  -d My-Profile-Name:/www/htdocs/$FileName
		Rozpocznij w: $FileDir

		
Zabrało mi trochę czasu zanim to zaczęło działać, pamiętaj, aby wstawić spacje w polu Parametry dokładnie jak wyżej i nie zapomnij, że jest to tak naprawdę jeden wiersz. Wyczyść wszystkie pola opcji w oknie dialogowym Narzędzia. Zastąp My-Profile-Name nazwą profilu, który sporządziłeś w WS_FTP, ale pamiętaj, że nazwa nie może zawierać żadnych spacji, w przeciwnym razie nie będzie działać. Jeżeli to konieczne zastąp "/www/htdocs" ścieżką do swoich plików na serwerze internetowym. Parametr następujący po "-s" to nazwa pliku źródłowego, gdzie "$FileName" rozwija się do nazwy aktywnego dokumentu a parametr następujący po "-d" to nazw pliku docelowego w składni WS-FTP.

Przesłał: Christopher Locke, Entropy Gradient Reversals, All Noise - All the Time, http://www.rageboy.com/

(David J. Evans dodał: "Udało mi się to zastosować dopiero po modyfikacji zdalnej ścieżki (remote path) przez usunięcie pierwszego / .... zakładając, że ścieżka jest podkatalogiem katalogu głównego, a więc / nie było potrzebne. Komunikaty błędów zgłoszone przez WS_FTP były tu mało pomocne!")


Publikacja dokumentu przy użyciu WS_FTP z alternatywnymi ustawieniami:

Próbowałem porady Christophera Locke'a dotyczącej stosowania WS_FTP z TextPadem. Jednak proponowane ustawienia w moim przypadku nie działają. Dokonałem w nich zmian:
		polecenie:		E:\Program Files\WS_FTP\WS_FTP95.exe
		parametry:	-p My-Profile-Name -s Local:$File -d
		My-Profile-Name:	$UNIXPath/$FileName
		rozpocznij w: 	$FileDir
		
Między moimi ustawieniami i Christofera występują dwie różnice:
1. z -s Local, ja użyłem $File zamiast $FileName;
2. Użyłem $UNIXPath zamiast wstawienia konkretnej ścieżki unix. Dokonałem tych zmian ponieważ struktura katalogów na mojej lokalnej maszynie odzwierciedla strukturę serwera uniksowego, tym sposobem $UNIXPath otrzymane z $Path będzie dokładnie odpowiadało ścieżce do pliku na serwerze uniksowym.

Przesłał: Feng Wu feng@systechusa.com, Systech Solutions Inc., Glendale, CA, USA.


@-Files:

Stosując "@-files", włączenie nazwy "@-file" do listy ułatwia dodawanie i usuwanie plików, za każdym razem kiedy jej używamy.
Podziękowania dla Ron "Quinn" Straight za tę poradę.


Drukuj wszystko:

TextPad posiada polecenie Drukuj wszystko, nie występuje ono jednak w menu. By je stosować trzeba mu przypisać skrót do polecenia w następujący sposób:
  1. Wybierz Preferencje z menu Konfiguracja.
  2. Wybierz "Klawiatura" w oknie dialogowym Preferencje.
  3. Z listy Kategorie, wybierz Plik.
  4. Z listy Polecenia, wybierz FilePrintAll
  5. Wybierz skrót w polu Naciśnij nowy klawisz skrótu.
  6. Kliknij Przypisz.
  7. Kliknij Zamknij.


Przeglądaj odpowiednik strony w Internecie:

Jeżeli przechowujesz stronę internetową na twardym dysku i stosujesz "adresowanie względne URL" - tzn. nazwy plików w URL to tylko same nazwy bez pełnych adresów internetowych - możesz skorzystać z takiego narzędzia użytkownika:
		Tekst menu:   Przeglądaj odpowiednik strony w Internecie
		Polecenie:     C:\Program Files\Internet Explorer\Iexplore.exe
		Parametry: http://www.MyWebSite.com/$FileName
		
Jeżeli edytujesz lokalną kopię strony internetowej, uruchom to polecenie, by zobaczyć ją na swoim serwerze internetowym.

Przesłał: Christopher Locke, Entropy Gradient Reversals, All Noise - All the Time, http://www.rageboy.com/


Szukanie i zastępowanie; Konwertowanie elementów META NAME

Czasami konieczne jest przetworzenie każdej linii META NAME na coś innego. W poniższym przykładzie, pobieramy informację z nagłówka artykułu Microsoft Knowledge Base i konwertujemy ją do XML. Zwróć uwagę, że nie jest to pełna konwersja, ale jedynie początek. Uważaj na dane przedzielone znakami zakończenia wierszy (dangling content). Wyrażenie regularne nie mogą zmienić elementów, których zawartość jest podzielona między wierszami.

ZNAJDŹ:
^[^"]+"\([^"]*\)"[^"]*"\([^"]*\)"*.*
ZASTĄP:
<\1>\2</\1><BR>

ZMIANY:

<TITLE>Q10022 - OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT</TITLE>
<META HTTP-EQUIV="CONTENT-Type" CONTENT="text/html; charset=iso-8859-1" />
<META HTTP-EQUIV="PICS-Label" CONTENT="(PICS-1.1 "http://www.rsac.org/ratingsv01.html" l gen true comment "RSACi North America Server" by "Inet@microsoft.com" for "http://support.microsoft.com" on "1998.02.17T12:28-0800" r (n 0 s 0 v 0 l 0))" />
<META NAME="ms.locale" CONTENT="EN-US" />
<META NAME="Category" CONTENT="Support; KB Article" />
<META NAME="Premium" CONTENT="Support" />
<META NAME="KBArea" CONTENT="Support; KB; word97" />
<META NAME="KBID" CONTENT="Q10022" />
<META NAME="KBTitle" CONTENT="OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT" />
<META NAME="Description" CONTENT="When you print an Encapsulated PostScript (EPS) file, the file may fail to print or may be printed incorrectly." />
<META NAME="Product" CONTENT="word97" />
<META NAME="KBCreate" CONTENT="April 6, 1984" />
<META NAME="KBModify" CONTENT="April 28, 1999" />
<META NAME="EditDate" CONTENT="January 22, 1999" />
<META NAME="Question" CONTENT="" />
<META NAME="Versions" CONTENT="WINDOWS:97; winnt:4.0" />
<META NAME="Component" CONTENT="" />
<META NAME="Technology" CONTENT="" />
<META NAME="Links" CONTENT="" />
<META NAME="Keywords" CONTENT="kbprint offwin offprint" />
<META NAME="Platform" CONTENT="WINDOWS winnt" />
<META NAME="Hardware" CONTENT="" />
<META NAME="SolutionType" CONTENT="kbfix" />
<META NAME="IssueType" CONTENT="kbbug" />
<META NAME="BoilerPlate" CONTENT="" />
<META NAME="ProducedView" CONTENT="" />
<META NAME="QUERYWORDS" CONTENT="EPS">
<META NAME="QUERYWORDS" CONTENT="filter">
<META NAME="QUERYWORDS" CONTENT="print">
<META NAME="QUERYWORDS" CONTENT="garbled">
<META NAME="QUERYWORDS" CONTENT="does">
<META NAME="QUERYWORDS" CONTENT="not">
<META NAME="QUERYWORDS" CONTENT="is">
<META NAME="QUERYWORDS" CONTENT="printed">

NA:

<TITLE>Q10022 - OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT</TITLE>
<CONTENT-Type>text/html; charset=iso-8859-1</CONTENT-Type>
<PICS-Label>(PICS-1.1 "http://www.rsac.org/ratingsv01.html" l gen true comment "RSACi North America Server" by "Inet@microsoft.com" for "http://support.microsoft.com" on "1998.02.17T12:28-0800" r (n 0 s 0 v 0 l 0))</PICS-Label>
<ms.locale>EN-US</ms.locale>
<Category>Support; KB Article</Category>
<Premium>Support</Premium>
<KBArea>Support; KB; word97</KBArea>
<KBID>Q10022</KBID>
<KBTitle>OFF97: EPS File Is Not Printed or Is Printed Incorrectly Under Windows NT</KBTitle>
<Description>When you print an Encapsulated PostScript (EPS) file, the file may fail to</Description>
print or may be printed incorrectly." />
<Product>word97</Product>
<KBCreate>April 6, 1984</KBCreate>
<KBModify>April 28, 1999</KBModify>
<EditDate>January 22, 1999</EditDate>
<Question></Question>
<Versions>WINDOWS:97; winnt:4.0</Versions>
<Component></Component>
<Technology></Technology>
<Links></Links>
<Keywords>kbprint offwin offprint</Keywords>
<Platform>WINDOWS winnt</Platform>
<Hardware></Hardware>
<SolutionType>kbfix</SolutionType>
<IssueType>kbbug</IssueType>
<BoilerPlate></BoilerPlate>
<ProducedView></ProducedView>
<QUERYWORDS>EPS</QUERYWORDS>
<QUERYWORDS>filter</QUERYWORDS>
<QUERYWORDS>print</QUERYWORDS>
<QUERYWORDS>garbled</QUERYWORDS>
<QUERYWORDS>does</QUERYWORDS>
<QUERYWORDS>not</QUERYWORDS>
<QUERYWORDS>is</QUERYWORDS>
<QUERYWORDS>printed</QUERYWORDS>

Przesłał: Anthony Missico, Jr., Independent Consultant, Missico Information Systems, www.missico.com


Dodatkowa uwaga do "Jak spowodować, aby Notepad używał TextPada zamiast WordPada dla dużych plików?"

Użytkownicy TextPada v4.x, którzy czytali Pomoc podręczna/Często zadawane pytania i zrealizowali poradę Jak spowodować, aby Notepad używał TextPada zamiast WordPada dla dużych plików? zauważą, że TextPad wywołany jest do otwierania plików programu Windows Write (z rozszerzeniem .wri) a może być to uciążliwe, ponieważ są to pliki binarne i wyświetlają się w formacie heksadecymalnym.

Jeżeli NADAL wolicie WORDPAD do czytania plików Windows Write jako tekstu, możecie spróbować:

W Eksploratorze Windows:

  1. Przejdź do C:\Program Files\Accessories\ i wybierz WordPad.exe. Skopuj i wklej plik, by otrzymać "Kopia WordPad.exe" i zmień jej nazwę na WordPad1.exe.
  2. W menu Podgląd Opcje Folderu\Typu plików, wybierz Dokument Write i kliknij Zawansowane, zmień program stosowany w akcjach open, print i printto z WordPad.exe na WordPad1.exe. (Windows 2000)
  3. Przejdź do skrótu C:\Windows\Start Menu\Accessories\WordPad.exe i w menu Edytuj właściwości menu zmień Element docelowy z WordPad.exe na WordPad1.exe.

Uważam, że jest to najlepszy sposób na połączenie możliwości edytorów Windows i TextPada v4.x.

Przesłał: Dave Rudd, AMIEE


Jak wykorzystać przyciski boczne IntelliMouse Explorer Microsoftu:

Mały i duży przycisk dla kciuka na myszce wysyłają takie same komunikaty jak Alt+Prawa strzałka i Alt+Lewa strzałka. Możesz więc przypisać im, na przykład, polecenia PageUp/Down TextPada w następujący sposób:

  1. Wybierz Preferencje z menu Konfiguracja.
  2. Wybierz "Klawiatura".
  3. Z listy Kategorie, wybierz "Kursor".
  4. Z listy poleceń, wybierz "PageUp".
  5. W polu skrótu klawiaturowego przyciśnij klawisz Alt i klawisz prawej strzałki.
  6. Kliknij Przypisz.
  7. Z listy poleceń, wybierz "PageUp ".
  8. W polu skrótu klawiaturowego przyciśnij klawisz Alt i klawisz lewej strzałki.
  9. Kliknij Przypisz.
  10. Kliknij OK.

Jak kompilować aplikacje Javy mające podane zmienne środowiskowe:

Przypuśćmy, że chcesz stosować serwlety i bazę danych Oracle, oraz że chcesz kompilować program Javy używając TextPada. Może się okazać, iż linia poleceń będzie tak długa, że trudno się nią posługiwać, wtedy prawdopodobnie ustawisz zmienne środowiskowe do zapisywania plików jar oraz ścieżki klas (classpath). Stosując normalny javac zainstalowany z TextPadem nie będziesz mógł znaleźć tych zmiennych, polecam co następuje.

Jeżeli w twoim c:\autoexec.bat występują takie informacje:

		SET PATH=%PATH%;c:\oracle\ora81\bin;c:\java\jdk12~1.2\bin;c:\java\classes
		SET CLASSPATH=c:\java\classes
		SET JARFILES=c:\java\classes\servlet.jar;c:\java\classes\oracle.jar
		
  1. W programie TextPad wybierz menu Konfiguruj w Preferencjach.
  2. Wybierz stronę Narzędzia.
  3. Kliknij przycisk Dodaj i wybierz polecenie "Polecenie DOS".
  4. Skopiuj następującą linię do pola:
    javac -classpath %JARFILES%;%CLASSPATH% -d c:\java\classes $File
    		(Uwaga: -d informuje javac, gdzie zapisać wygenerowane pliki klas.)
  5. Kliknij przycisk OK.

W Ustawieniach, należy podać następujące informacje:

Polecenie: COMMAND.COM
Parametry: javac -classpath %JARFILES%;%CLASSPATH% -d c:\java\classes $File
Rozpocznij w: $FileDir
Przechwyć rezultat:Wybrana
Sygnał dźwiękowy po ukończeniu:Wybrana
Wyrażenie regularne: ^\(\(\(\\\\[^\]+\\[^\]+\)\|\([A-Za-z]:\)\)[^:]+\):\([0-9]+\):
Rejestry:File=1, Line=4

Przesłał: Garth Fielding


TextPad i LaTeX

Najważniejszym celem podczas edycji źródeł LaTeX jest maksymalne skrócenie cyklu edycji, kompilacji, podglądu i ponownej edycji.

By go osiągnąć, konieczne jest przygotowanie wszystkich potrzebnych narzędzi. TextPad (do uruchamiania kompilatora TeX i przeglądarki DVI), kompilator TeX (aby można było przechodzić bezpośrednio do zgłoszonego błędu wpisując "e") i przeglądarka DVI (aby przez podwójne kliknięcie przechodzić do akapitu w TextPadzie).

Ilustruję ustawienia programem TeX z dystrybucji MiKTeX, ponieważ taki właśnie posiadam. Ustawienia powinny jednak działać z innymi dystrybucjami. Trzeba jedynie znaleźć właściwe miejsce do podania ustawień.

Praca z LaTeX

Ponieważ TextPad nie został zaprojektowany z myślą o programie LaTeX, konieczne jest wybranie odpowiedniego sposobu na wykorzystanie wszystkich zalet naszych ustawień.

Po pierwsze musisz zdecydować do czego będziesz używał LaTeX. Czy masz plik główny zawierający kilka innych plików? Lub czy masz jednoplikowe projekty LaTeX.

Poniżej opiszę jak ustawić TextPad do pracy z plikiem zawierającym inne pliki. Jeżeli pracujesz z jednym plikiem, musisz odpowiednio zmodyfikować ustawienia.

Wynika to z tego, że nasze narzędzie może przyjąć nazwę bieżącego pliku lub grupy roboczej. Jeżeli zrobimy to pierwsze, musimy przejść do pliku głównego projektu by wywołać kompilator TeX. W przypadku kilku otwartych plików nie jest to wygodne rozwiązanie.

Generalną zasadą jest więc tworzenie obszaru roboczego TextPada dla każdego projektu LaTeX o tej samej nazwie co nazwa projektu LaTeX. Tym samym możemy pracować w każdym pliku projektu i zawsze kompilujemy plik główny. Innym rozwiązaniem będzie stosowanie zawsze tej samej nazwy dla pliku głównego (np. glowny.tex, main.tex).

Ponieważ mam niemiecką wersję TextPada tłumaczenia etykietek pól edycji nie są najbardziej dokładne :-)

TextPad

Wyłącz "Zezwól na równoczesne używanie wielu kopii TextPada"! W przeciwnym wypadku przejście z przeglądarki DVI do TextPada będzie otwierało nową kopię TextPada, a praca nie będzie możliwa ponieważ nie będzie w niej właściwego obszaru roboczego.

Utwórz 2 nowe narzędzia:

Kompilator TeX jako polecenie DOS:

		Parametr:                    texify --src $WspBaseName.tex
		Katalog początkowy: $WspDir
		

Warto zapisać wszystkie pliki i zamknąć okno po wykonaniu. Nie przechwytuj rezultatu (!).

--src wstawia specjalne kody do źródeł pozwalające na odwrotne przeszukiwanie (inverse search).

W pojedynczym pliku LaTeX wystarczy zastąpić obszar roboczy plikiem (użyj $FileName i $FileDir zamiast $WspBaseName.tex i $WspDir).

Podgląd DVI jako program:

		Program:    yap.exe
		Parametr:  -1 -s $Line$FileName $WspBaseName.dvi
		Katalog początkowy: $WspDir
		

Wstaw swą ulubioną przeglądarkę DVI zamiast yap.

-1 każe yap używać tej samej instancji programu
-s nakazuje yap przeszukiwać do przodu. Działa to nawet w plikach, które nie są plikami głównymi. yap otworzy się w miejscu kursora w bieżącym pliku.

W jednoplikowym projekcie LaTeX użyj $BaseName i $FileDir zamiast $WspBaseName i $WspDir.

Przeglądarka DVI (yap).

W "View", "Options...", "Inverse Search", "Command line" wstaw

		textpad "%f"(%l)
		

Spowoduje to wywołanie TextPada po podwójnym kliknięciu w przeglądanym dokumencie.

TeX

Jeżeli TeX natrafi na błąd, pojawi się komunikat na ekranie - naciskając "e" możesz przejść do edycji pliku. To jaki edytor jest wywoływany ustawione jest w pliku INI MiKTeX, inne dystrybucje powinny także gdzieś podobne ustawienia.

Utwórz nowy plik (mymiktex.ini) i wstaw do niego

		[TeX]
		Editor=textpad "%f"(%l)
		

Następnie wywołaj

		initexmf --personal=mymiktex.ini
		

Odtąd wpisanie "e" będzie wywoływać TextPad zamiast notepada.

Umlauty i akcenty

Nie będzie potrzeby wprowadzania makra zastępującego umlauty i znaki akcentowane na reprezentację TeXa (ä -> "a), jeżeli używasz inputenc-package

		usepackage[ansinew]{inputenc}
		

w preambule do swego pliku LaTeX. Wtedy możesz stosować wszystkie znaki, które można wpisać. Sprawdzałem to z niemieckimi umlautami oraz akcentami ´,` i ^.

Przykład

Otóż to! Wszystko zostało ustawione do stosowania TextPada:

  1. Utwórz nowy plik TeX, np. "PierwszyTest.tex".
  2. Zapisz nowy obszar roboczy. Nie musisz nawet wpisywać "PierwszyText.tws", bo o to zatroszczy się TextPad.
  3. Edytuj plik "PierwszyTest.tex".
  4. Uruchom narzędzie "texify", aby utworzyć plik DVI.
  5. Jeżeli wystąpią błędy, możesz je poprawić wpisując "e".
  6. Uruchom narzędzie yap, aby zobaczyć rezultat. yap przejdzie do akapitu, w którym obecnie znajduje się kursor.
  7. Podwójne kliknięcie gdziekolwiek w yap spowoduje przejście do odpowiedniego akapitu w TextPadzie.

Przesłał: Jens Hollmann. 12 października 2001.