TextPad Search  |  Contacts  |  Home   
support
Feedback  |  FAQ  |  Tips  |  Release Notes  |  Mailing List  |  Forums

 


Release 4.5

This release implements the following enhancements, and fixes problems that have been reported in version 4.4:

Enhancements:

  • Windows XP ready: conforms to the look and feel of this operating system; uses InstallShield 6.30 for installations.
  • Implemented a command to set keyboard focus to the last active view, when it is in a modal dialog box. It is necessary to assign a shortcut key to View.ActivateView, before it can be used.
  • Added a toolbar button for the Reformat command.
  • The online help has been translated to Polish.
  • When registering TextPad as an HTML editor for IE, the registry entries have been adjusted to match the way IE 5.5 does it.
  • Changed the regular expression to match the output of the JDK compiler to match files without paths.
  • New options to disallow use of the File Open command and to apply user capabilities restrictions to Administrators.

Issues addressed:

  • Strings such as L"Unicode" were never terminated by the syntax highlighter.
  • Bookmarks were not redrawn, after transposing a line with a bookmark.
  • A URL had to be left clicked, before it appeared on the context menu.
  • New document class name did not accept DBCS.
  • Delete trailing spaces while saving did not work for DBCS spaces.
  • A file was treated as UTF-8, if it contained consecutive characters such as "ö" or "﫿#".
  • No warning was issued about null characters, when copying bookmarked lines.
  • The syntax highlighter missed keywords such as "variable.keyword", if any keywords contained a ".".
  • When doing a numeric sort, 0x, where x is any character, was ordered according the the character code of x.
  • Outside of a string, StringEsc only escaped StringStart, not StringAlt.
  • The default printer was used, when an associated file was dropped onto another printer icon.
  • On Windows 2000, when DOS tools are run, execution of AutoRun commands from the registry is now disabled.
  • The temporary batch file, used for some tools such as Run Java Application, is now deleted after 10 minutes rather than 1 minute.
  • When the view height was an exact multiple of the font height, and a document exactly fitted the view, cursor down would not move the cursor to the last line.
  • Saving a Unicode or UTF-8 file as ANSI saved it as OEM/DOS.
  • After a right button drag/drop move, the context menu should not have popped up.
  • Fixed 256 byte memory leak when switching between fixed width fonts.
  • When saving to certain non-Windows network drives, "Another application has updated the file" was erroneously reported.
  • The Defaults button on the Find in Files dialog box did not set all the intended defaults.
  • Files containing only the characters "m .," are no longer treated as Unicode.
  • The Auto-correct button on the spell check dialog box should not have been enabled for repeated words.
  • When printing a wrapped line that extended over more than one page boundary, it was truncated.
  • When a document class font was changed, it was not updated in Unicode documents.

top


Release 4.4

The initial release consolidates all the updates and fixes in TextPad 4.3. See below for details of changes in 4.4.1 and 4.4.2.

The enhancements in this release are:

  • The online help is now available in German.
  • The American and British English spell checking dictionaries have been updated.
  • For non HTML documents, the View in Web Browser command can be used to open the URL under the cursor. To do the same with HTML documents, hold the Shift key down.

The issues addressed in this release are:

  • When associating TextPad as the Edit command for a file extension, such as .BAT, the wrong icon was used.
  • Document tabs were not displayed correctly, after the last visible one was closed, and the tabs had been scrolled to the right.
  • The hypertext jumps parameters of the Command Results window were not saved in the workspace archive.
  • Crash if the registers used in the regular expression to match the output of a tool were out of bounds.
  • If an alphanumeric string, such as "REM", was defined as the start of a freely positioned, single line comment, any word prefixed by that string was treated as the start of a comment.
  • Crash on Windows 9x/ME, after changing the default paper orientation for printing, without also changing the printer.
  • When the deletion of the current line caused the view to scroll, because the remaining lines all fitted, the cursor ended up on the wrong line.
  • Crash when renaming a document to a non-existent folder.
  • Intermittent crash after a document class was changed, as a result of saving it with a different name.
  • For new installations, the toolbar buttons should have defaulted to flat.
  • If a comment line ended with a valid DBCS lead byte, an extra garbage character was displayed.
Issues addressed in 4.4 Revision 1:
  • The font used for the IME did not match the font in the active view.
  • On Windows 2000, the IME can now be used when the default code page does not match the input language.
  • On NT/2K, copy and paste now works between documents that don't use the default code page.
  • The Windows 2000 File Open dialog box is implemented on that platform.
  • Replace, on the Replace dialog box, should only have made a replacement when the search string was matched.
  • In rare circumstances, file compare missed differences between files.
  • On the secondary monitor of a dual monitor system:
    • TextPad always restarted on the primary monitor.
    • Document selector popup tips did not work.
    • Full screen mode always switched to the primary monitor.
    • Could not freely position the document selector or clip library.
  • Fixed crash when reformatting text with more leading spaces than the new line length.
  • When opening #include files, the INCLUDE environment variable is now searched before the Visual C++ search path, to make it easier to use other compilers on a system with VC++.
  • The View in Web Browser command now works for files with extensions that are not associated with the default browser.
  • CEditorDoc::OnSaveDocument did not convert from DOS to ANSI.
  • The working directory was not updated after a document was renamed.
  • It should not have been possible to paste multiple lines into the "Find what" box.
  • When the start of a multiple line comment was dragged and dropped past the last line in a view, the syntax highlighting of affected lines was not updated.
  • The print preview page number was cleared from the status bar, when it was clicked.
  • The Rename command should have been disabled when the policy setting disallowed Save As.
  • The policy to disallow editing existing files was broken.
  • For DOS files, page headers and footers displayed file names in ANSI.
  • On Windows 2000, associating a file extension changed a value that effectively deleted the association for other user names.
  • The syntax scanner allowed the characters F, L and U (upper or lower case) to be postfixes to numbers, when they were declared as single character keywords.
  • When replacing in a selection, the last line of which is only partially selected, the first instance after the selection, on the same line, was replaced.
  • On NT 4, if the registry contained an empty key like HKCR\.xyz, the whole of HKCR was duplicated under HKCR\TextPad.xyz, when ".xyz" was associated with TextPad.
  • Optimized the determination of the actual case of file path names, to reduce the time it takes to open files over low bandwidth networks.

Corrections implemented on 14-Feb-2001:

  • Text composed in the IME was only read when it was closed, so intermediate completed phrases were discarded. This only affected far-eastern languages.
  • The regular expression "\&", which matches anything, was broken.
Issues addressed in 4.4 Revision 2:
  • The user interface is now available in Polish.
  • In a once-only action on Windows 2000 and NT 4, preferences are now initialised from registry key HKEY_USERS\.DEFAULT\Software\Helios\TextPad 4, if it exists.
  • Implemented Ctrl+C/V shortcuts in the clip library.
  • When multiple lines are pasted into the Find/Replace dialog boxes, "\n" is now substituted for the end of line characters.
  • Japanese IME reconversion is now implemented.
  • On Windows 2000, the indicator text on the status bar disappeared in various circumstances.
  • The correct Open File dialog box is implemented on Windows ME.
  • Continuation lines of a multiple line string could be interpreted as comments by the syntax highlighter, if they started with the appropriate characters for comments.
  • Find/Replace/Find in Files commands now set the focus to the Find What box, if the dialog box is already displayed.
  • Tabs should not have been converted to spaces by the Replace command.
  • Replacing individual instances of text matching multiple line regular expressions did not work.
  • The total page count (&P) and use of bold and italic fonts in page headers/footers did not work for documents with private document properties.
  • When Configure/Preferences/File/Auto-reload was checked, binary files were not released when they were closed.
  • Paper size and orientation can now only be set for printers that support it.
  • When printer margins are too big, they are now set to the maximum, instead of minimum value.
  • Filename wild cards with 3 character extensions matched extensions with 4 or more characters (e.g. *.htm also matched *.html).
  • If a Unicode file was saved as DBCS, by another instance, it was still shown as Unicode when it is reloaded.
  • The UTF-8 signature was stripped from existing files, when they were saved.
  • Find/replace with regular expressions worked unpredictably, when a lot of registers were used.
  • The Save As command did not preserve original line endings for files with mixed ones.
  • The last line of a file is no longer automatically terminated, for files with non-standard end of line characters.
  • If only a tool's command line was changed, the changes were lost when the Preferences dialog box was closed.
  • When word wrap was on, and a wrapped line was deleted that was before the first visible line, TextPad sometimes crashed.
  • When lines with more leading spaces than the width of the view were wrapped, characters after the leading spaces were not displayed.
  • When Find in Files searched subfolders from the root of a drive, it missed the first folder (in folder creation order).
  • The clip library edit control did not word wrap.
  • On the context menu for the document selector, "Show full paths" was never checked.
  • When "Show full paths" was toggled, file names were not updated for documents whose properties had been modified.
  • The background color is no longer printed for line numbers.
  • The sort option to delete duplicate lines did not take account of case insensitive keys.
  • When a multiline string contained an alternate string terminator, and was only partially visible, its syntax highlighting was incorrect.
  • If a keyword in a syntax definition file contained a punctuation character (e.g. "."), that character was always treated as part of a word, when selecting or moving by word.
  • If a syntax definition file defined StringStart = " and StringEsc = \, the double quote in \" was treated as the start of a string.

top


Release 4.3

This release implements the following enhancements, and fixes problems that have been reported in version 4.2:

  • Document class properties can be overridden for individual documents, using the Document Properties command on the View menu.
  • The Command and Search results windows have their own document classes.
  • The code page for Unicode conversions now corresponds to the selected font script for the document.
  • The font used for the Find and Replace edit controls now matches that of the active document.
  • DOS files are now always edited in the DOS code set. The option to convert automatically between DOS and ANSI has been eliminated.
  • The dialog box for editing clip library entries now makes it easier to define "hot spots".
  • Items on the Find/Replace history lists can now be deleted, using context menu commands.
  • The font selector now distinguishes between raster, vector, TrueType, OpenType and Adobe fonts.
  • The color selection listbox now shows the actual color for each item.
  • New command to copy the file names of all open documents to the clipboard.
  • Binary views have been reformatted, so that each byte is displayed separately.
  • Can now easily associate file names without an extension, except on NT 3.51, Windows 2000 and ME, which don't support it.
  • To conform to the Application Specification for Microsoft Windows 2000, and provide support for roaming users, new installations will store store application specific data in the "[user profile]\Application Data\TextPad" folder, rather than the USER subfolder of the TextPad installation folder.
  • Adheres to MS Windows system-level group policies for the following keys: NoRun, NoRecentDocsHistory, NoWelcomeScreen, NoSaveSettings, NoSetTaskbar and NoShellSearchButton.
  • If a user tool outputs line and column numbers, without a filename, the filename of the last active document can be implied, by leaving the file register for the regular expression blank for that tool.
  • The search path for include files is now initialized from that specified for Visual C++ 6, if appropriate. Otherwise, the INCLUDE environment variable is used, as before.
  • Fixed length keywords can now be used for syntax highlighting, by using the new KeyWordLength parameter in syntax definition files. This allows runs of undelimited keywords, such as "CGAT" in DNA sequences. See DNA.SYN, in the SAMPLES subfolder, for an example of its use.
  • The InitKeyWordChars and KeyWordChars parameters are no longer needed in syntax definition files, eliminating the possibility of mismatches between them and the actual characters used in keywords.
Issues addressed in 4.3 Revision 1:
  • Raster fonts could not be used with non-Western scripts.
  • The WordLeft and WordRight cursor motion commands did not behave correctly, with some syntax definition files.
  • The active document was not saved for user tools referencing parameter $FileName.
Issues addressed in 4.3 Revision 2:
  • Popup tips for user tool buttons on toolbars should have displayed the tool name.
  • Could not specify which characters were considered to be part of a word.
  • Crash after a search for a string of more than 1000 characters was not matched.
  • Crash after searching for a string of more than 1065 characters on NT 4.
  • The document selector can now be docked on any side of the main window. (Requires the deletion of registry key HKEY_CURRENT_USER\Software\Helios\TextPad 4\Docking.)
  • Explorer now starts in the current working folder.
  • Windows system policies are only adhered to if enabled under registry key HKEY_CURRENT_USER\Software\Helios\TextPad 4\Policy.
  • The list of recently used files was not saved, if the system policy "NoSaveSettings" was set.
  • Regular expressions [:blank:] and [:space:] did not match tabs.
  • Courier New did not enumerate the DOS character set.
  • File names could not start with '@'.
  • Crash when comparing files with very long names.
  • Tab stops could be one pixel wide, therefore invisible, with proportionately spaced fonts.
  • Ctrl+Shift+F6 restored all MDI windows.
  • When the list of tools on the Tools property page had a scroll bar, its toolbar was truncated.
  • If the character set was not specified for a clip library, the wrong font could be used, when switching from the DOS characters clip library.
  • Drag and drop locked up, if a file change notification occurred while dragging.
  • The selection was cleared, after using any of the commands to change case.
  • Rare, non-repeatable crash when inserting in block mode beyond the end of a line.
  • The tile window commands could not be recorded.
  • The Playback Macro dialog box would not work, if the "specified number of times" box did not contain a number.
  • The option to extend the selection, on the Find dialog box, only worked for the first Find Next.
  • After cancelling a right button drag, the context menu was displayed.
  • To reduce the risk of file change notifications being missed, due to the 2 second time stamp resolution in Windows, the file size is now compared as well.
  • Indent Less reduced the selection by one line, if no lines could have their indentation reduced.
  • DBCS character 0x815B should have been included as part of both Katakana and Hiragana.
  • If the Ctrl key was held down when the Print button was clicked, the Page Setup dialog box should have been displayed.
  • If part of an indented line was selected, and its indentation was reduced, cursor left did not go to the start of the line.
  • Form feed was treated as a space, when word wrapping, so the rest of the paragraph was indented.
  • If "abc*.ext" was in a list of document class members, it did not match "abc.ext".
  • Replacing "de" with nothing, when "abcde" was selected in string "abcdede", deleted the second "de".
  • The regular expression [0-9]*[0-9] did not match numbers.
  • The first run after the setup program finished should have been in the setup language.
  • The Save All command was enabled while a user tool was running.
  • An invalid file name, in the Compare dialog box, prevented the Browse dialog box from being displayed.

Release 4.2

This release fixes problems that have been reported in version 4.1, and implements the following enhancements:

  • Support for Unicode and UTF-8 files. These encoding formats are automatically recognized when files are opened, and can be selected when saving. The Compare command can now compare files of different format, and the Find in Files command can search through files of these formats.
  • A wizard for creating document classes.
  • Option to make the Find and Replace dialog boxes transparent, when they do not have input focus. This feature requires Windows™ 2000.
  • The Sort command now works with floating point numbers.
  • Enable Undo command on the Configure menu. Disabling Undo can speed up macros and the Replace All command.
  • New command to save and close the active document. The FileSaveAndClose command is not on a menu, so cannot be used until it has been assigned a shortcut.
  • The online help now uses HTML Help format. Windows 95 users may need to download Microsoft's HTML Help Engine, if it is not already installed on their system.
  • New tool parameter macros: $AppWnd, $DocWnd, $WspBaseName and $WspDir. These respectively expand to the handles to the main and document windows, the base name of the current workspace file and its folder.
  • Policy to disable copying to the clipboard and drag and drop editing. Gives additional control to those working with high security data.
Issues addressed in 4.2 Revision 1:
  • Unicode files could not be opened or saved on NT 4.
  • Java applet windows were always closed on exit.
  • The regular expressions [a-z] and [:lower:] only worked when match case was checked.
  • The tool parameter macro $WspDir worked inconsistently.
  • The online help no longer stays on top.
Issues addressed in 4.2 Revision 2:
  • Crash when starting with "-p" in the command line, without a filename.
  • Could not open Unicode files larger than 512 KB.
  • The test to determine if a file is Unicode is now stricter.
  • Trailing spaces were not handled correctly, when word wrapping comments and strings, so they were wrapped to the start of the next line.
  • The document selector was not updated, when only the case of a file name was changed.
  • Replace All of a regular expression ending in "\n", with nothing, missed alternate lines.
  • Shortcuts to workspaces were opened as ordinary files by Quick Open, the command line, or when dragged and dropped.

Release 4.1
This maintenance release fixes problems that have been reported in version 4.0, and implements the following enhancements:
  • Eliminated the need for the setup program to have NT administrator privileges.
  • JDK commands are now automatically added to the Tools menu, if the JDK has already been correctly installed, using its setup program.
  • New Page Setup command on the File menu, for quick access to the printer settings of the document class of the active document.
  • New "Paste as Block" and "Paste as Lines" commands on the Edit menu, override the format of text on the clipboard.
  • The Japanese edition now has online help in Japanese. Many thanks to Takayuki Y Okada for contributing this translation.
  • New "StringsSpanLines" and "HexPrefix" directives in syntax definition files.
  • The character set can now be specified in clip libraries, using the "CHARSET=" directive. Its use is demonstrated in the new "DOS Characters" clip library.
  • New "$DOSBaseName" macro for tool parameter macros.
  • When block selection mode is changed, selections in all views are updated to match.
  • The details of the File Open and Save As commands are now recorded in macros.
  • Holding the Shift key down, while minimizing or restoring documents, repeats the command for all open documents.

top


Release 4.0
This release is significantly different from TextPad 3.x, so please note the following points, if you are upgrading.
Features that are implemented differently:
  • File names can now be associated with document classes, using wild cards, and each class can have different properties, such as tab stops, font and syntax highlighting. The way such properties are defined and saved has been completely redesigned, so no user preferences are automatically transferred from TextPad 3.x.
  • When TextPad is first installed, it creates document classes for plain text, binary, C/C++, htm and Java files. Any files that are not defined as members of any of these classes use the properties defined for the Default document class. Properties such as font, tabs stops and printed page layout must now be defined for each document class, using its properties page on the Preferences dialog box.
  • The engine for the spelling checker has been replaced with a more powerful, but incompatible one. Replacement dictionaries are available for all previously supported languages, plus new ones for Portuguese (for both Brazil and Portugal), Finnish, and English Legal and Medical terms.
  • The method of switching block (column) selection mode on and off has been changed to be consistent with the way it works in applications such as Microsoft Word. Now, the setting on the Configure menu controls the mode of the next selection, which can be temporarily overridden by holding the Alt key down, while drag selecting with the mouse. It no longer changes the mode of the current selection.
  • Multiple, named workspaces can now be saved, with each preserving the state of the set of documents you were working on when the workspace was saved. The single, unnamed workspace of TextPad 3.x is no longer available.
  • The JDK command to run a Java application no longer uses RUNJAVA.BAT. A separate command is used to run Java Applets, which automatically creates an htm wrapper, if necessary. RUNJAVA.BAT is included in the SAMPLES folder, in case you still need it.
The full list of enhancements is:
  • Color syntax highlighting.
  • Multiple workspaces.
  • Customizable toolbars.
  • Dockable document selector.
  • Alternative tabbed document selector.
  • Full screen view mode.
  • Document properties are associated by file name.
  • Proportionally spaced fonts.
  • Support for double byte (Asian) character sets.
  • Japanese user interface.
  • Variable tab stops.
  • Drag selection by word line and paragraph, with an option to include trailing spaces when selecting words.
  • The 4KB limit on line lengths has been removed.
  • The 32K limit on the number of word wrapped lines has been removed.
  • Improved performance with very large files.
  • Improved handling of files with non-standard end of line characters.
  • File locking.
  • Clip library entries can be individually edited.
  • New options on the Find dialog box to find in all documents, and to wrap at end of file.
  • The Find and Replace All commands can be interrupted.
  • All bookmarks can be inverted.
  • Four-way splitter with per view cursor and selection.
  • The selection is grayed out in inactive views.
  • Rename command.
  • Justify command.
  • Copy file name command.
  • Insert Statistics command.
  • The Insert File command can now insert more than one file at a time.
  • Visible display of spaces, tabs and line breaks can be individually controlled.
  • Backups in relative folders.
  • Option to defer the display of captured Tool output until it has completed.
  • Per Tool hypertext jumps
  • Commands to switch block selection mode on and off (no default shortcuts) for use with keystroke macros.
  • Double left clicking the background window runs the Open File command.
  • Consecutive backspaces or deletes are undone as an atomic operation.
  • The Quick Open command now supports NTFS alternate data streams.

top


Release 3.2
Changes and Enhancements:
Release 3.2.5
  • Updated the interface to CSE htm Validator 3.0, which locates errors by character position as well as by line number.
  • The Go To File command can now be used to send a URL to your default web browser.
  • Added command line parameters "-ca" and "-cd" to open files listed on the command line in the ANSI or DOS code set respectively.
  • The paper size selected for the printer is now persistent. (32-bit edition.)
  • Added a section to the online help about customizing the Macros menu.
Release 3.2.4
  • Changed the Window Tile commands to use Microsoft's terminology (in English).
Release 3.2.3
  • The IntelliMouse wheel now scrolls the window under the cursor, rather than the focus window.
  • Added ".SHTM" to the list of htm extensions.
  • Increased the number of file extension filters to 16.
  • New tool parameter macros $SelLine and $SelWord, for selecting and substituting the line or word under the cursor.
Release 3.2.2
  • New Tool Parameter Macros, $Prompt and $Password for specifying parameters at run time.
  • In MS Mouse compatibility mode, mouse activation no longer changes the cursor position.
  • The Quick Open command now changes the current working directory to match the file path.
Release 3.2.1
  • Printing odd and even pages, for double sided printouts.
  • Optional POSIX syntax for regular expressions.
  • ASP and WRL are now recognized as extensions for htm documents.
  • Repainting has been optimized when running macros.
  • The Stay on Top command now precedes Close on the System menu.
  • Automatic substitution of htm syntax for high-ANSI characters can now be controlled with an option on the Spelling tab of the Preferences dialog box.
Release 3.2.0
  • Polish user interface.
  • POSIX standard P1003.2 regular expression compatibility, including operators for matching zero or one ("?"), a specified range of matches ("\{min,max\}"), character classes (e.g. "[:alpha:]"), and alternation ("this\|that").
  • View in Web Browser command on the View menu.
  • The setup program detects if the Java Development Kit (JDK) has been installed, and gives the option to add compile and run commands to the Tools menu.
  • The popup menu for the New button on the Tools tab of the Customize dialog box also displays a command to install the JDK commands, if appropriate. (32-bit edition only.)
  • A command to run htm Validator is automatically added to the Tools menu, if that application has been installed. The popup menu for the New button on the Tools tab of the Customize dialog box also displays a command to add configuration tools for the validator. (32-bit edition only.)
  • The Document Selector now supports multiple selection for the Close and Print commands on its context menu, and the 32-bit edition has new commands to tile the selected windows.
  • New option on the Document tab of the Preferences dialog box to terminate the last line automatically.
  • New command on the Edit menu to insert the file name of the active document.
  • New option on the Print Setup dialog box to specify double spaced printing.
  • New option on the Compatibility tab of the Preferences dialog box dialog box to choose Microsoft's conventions for mouse click selection.
  • New option on the Quick Open (Ctrl+Shift+O) dialog box to search for the specified file or wild card in all subfolders.
  • The Clip Library for htm characters has been extended to include all those defined for the ISO-8859-1 (Latin-1) character set in htm 4.0.
  • The spelling checker now handles word containing embedded htm characters, such as "é".
  • High ANSI characters typed in htm documents are automatically substituted with the equivalent htm syntax.
  • In LaTex documents, the spelling checker now interprets double quotes before one of "OoUuAas" as the corresponding "ÖöÜüÄäß". It also skips text between "$ ... $", and in contexts such as "\cite{ ... }".
  • Files larger than 32kb are now e-mailed as attachments, and there is a new option on the Document tab of the Preferences dialog box to force all E-mail to be sent that way.
  • The View.ActivateClipLib command (Alt+0) now toggles the focus between the Clip Library and the active document.
  • The destination line of a go to or bookmark command is now briefly highlighted.
  • The positions of the Command and Search Results windows are now persistent.
  • If the cursor is at the end of the document when its file is reloaded, as a result of changes made by another process, it will be moved to the new end of document, thus tracking the end of file.
  • The option to minimize the main window when the last document is closed can now be overridden by holding the shift key down.
  • It is now possible to restrict the ability of a user to make and save changes, manage files, and work with external tools.
  • If a startup folder has been specified on the Folders tab of the Preferences dialog box, and the current working directory has not been configured to follow that of the active document, the working directory will be reset to the startup folder, when the last document is closed.
  • After a print preview, the cursor is now moved to the top of the last page viewed, unless it is the initial page.
Bug Fixes:
Release 3.2.5
  • Clip Library insertions should not have added an extra new line.
  • The Tile commands on the Window menu were the wrong way round in the French, Italian, Portuguese and Spanish user interfaces.
Release 3.2.4
  • Reverse searches matched arbitrary characters on the last line, after wrapping around the start of the file.
  • Delete after backspacing in overtype mode deleted the wrong character.
  • Clip Library entries longer than 256 characters were split into multiple lines.
  • Only the first 10 file filters were loaded.
Release 3.2.3
  • The spelling checker stopped on a word that was too long.
  • The spelling checker did not trap words beginning with numbers.
  • The spelling checker prompt for proper nouns is no longer made for German words.
  • In LaTex documents, words such as F\"ommer were wrongly spell checked as mmer.
  • The RE "\n" did not match the first end of line, if the cursor was already there, or for empty lines.
  • Registers were not allocated correctly for multiline regular expressions.
  • The active document is no longer saved when running a tool with the parameters FC_FileName or FC_BaseName.
  • GPF running macros between two documents.
  • The cursor column is now maintained when deleting lines.
  • When a file was already open, clicking its shortcut should not have rewound it.
  • Could not select all in a document consisting of entirely blank lines.
  • File change notifications could be missed when TextPad was minimized.
  • The 16-bit edition added 100 to short form dates > 1999.
  • Reverse searches for multiple new lines crashed after wrapping around at the start of the document.
Release 3.2.2
  • Multiple instances are now detected by a mechanism that is more reliable when the system is busy.
  • The Save button is now disabled when the last document is closed.
  • Relative paths in the Command Results window did not work with hypertext jumps.
  • Extending selection with Shift+Left click in the left margin did not work in MS mode.
  • Reverse find failed to match patterns at the start of a line.
  • The number of selected lines was not updated on the status bar when scroll selecting with the mouse.
  • The selection was not updated to show different length spelling corrections.
  • The "Regular Expression" setting did not operate correctly in the 16-bit edition.
  • The full pathname was not shown for binary views.
  • Replace All in a selected column could leave the wrong text selected.
Release 3.2.1
  • Spell checking crashed when the last line was unterminated, and the last word should have been ignored, because it was all capitals, or contained a number.
  • Redundant "MDI" entries could appear on the Window menu.
  • The keyboard layout was not correctly identified on NT 3.51
  • Only the first file matching a wild card was opened when started from command line, and only one instance was allowed to run.
  • Under certain circumstances, the prompt to reload externally modified files stopped being given.
  • Sorting and deleting duplicates, when everything was selected, and word wrap was on could result in a crash.
  • Could not split an unterminated wrapped line.
  • Replace All did not stop at the end of the current selection, if it was in the middle of a line.
  • Inserted text could be indented to align with the previous line in the wrong circumstances.
  • Down arrow ended up in the wrong column after splitting a line with Enter.
  • Block selection behaved strangely when a new document was opened, and the cursor was normally constrained to the text.
  • Go to column should not have flashed the line.
  • Couldn't escape the regular expression "\n" with "\\n".
  • If Replace All deleted the line containing the cursor, the selection was incorrect.
  • Ctrl+Shift+Tab did not cycle through documents in exactly the reverse order of Ctrl+Tab.
  • Could not right click the context menus for the Selector, macros and Clip Library.
  • The Selector and Find/Replace dialog boxes could not be used on virtual displays.
Release 3.2.0
  • Block mode should have been cleared when re-enabling word wrapping, after closing all documents.
  • File extension dependent behaviour was not implemented correctly for newly created files.
  • Focus was lost when replying to multiple "Reload" dialog boxes.
  • The Window Selector lost focus after selecting an iconized document.
  • Dropping a file, when in print preview mode, messed up the menu bar.
  • An INCLUDE environment variable could not have spaces between paths, and included files were not explicitly searched for in the directory of the parent document.
  • The number of copies to print was not reset to 1 after each printout.
  • The limit of 4 macros in unregistered copies has been removed.
  • Could not record File.New (Ctrl+N) in a macro.
  • Substituting the new file name in $File, when saving an untitled document before running a user tool.
  • The reformat margin was too small by 1 column when word wrapping was on.
  • On NT, if a window's title bar was clipped, it became invisible when the workspace was restored.
  • The 16-bit edition did not free printer device contexts.
  • The French spelling checker could cause lock ups.
  • Only the first 255 characters of each line were printed by the Compare command.
  • The Close All command would close the Command Results window, without prompting, while a user tool was running.
  • Commands on submenus of the Edit menu ignored shortcuts, after being popped up on a read only document.
  • The 16-bit edition wrongly used the language set for Windows, to determine the keyboard language.
  • Ctrl+Tab did not always cycle through the documents in the correct order.
  • The Reformat command could corrupt up the last line, if it was unterminated and word wrap mode was not enabled.
  • Clip Library inserts did not get indented correctly.

top