TextPad Szukaj    Kontakt    Strona główna   
wsparcie techniczne
Uwagi  |  FAQ  |  Porady  |  Informacje o wersji   |  Lista dyskusyjna  |  Forum 

 

Pierwsze kroki w C#

C# stanowi następną generację zorientowanego obiektowo języka C wprowadzoną przez Microsoft. Jest podobny do C++, ale bez jego najbardziej odstraszających elementów i pozbawiony zbędnego bagażu naleciałości z C. Przedstawiono go jako część strategii .NET i wydano wersję przeglądową (technology preview), która zawiera kompilator wiersza polecenia. Kompilator ten może być zintegrowany jako narzędzie programu TextPad, dając możliwość kompilacji edytowanego kodu i używania rezultatu kompilacji do przechodzenia bezpośrednio do zgłoszonych przez narzędzie błędów. Program obsługuje także wyróżnienie składni C# kolorem.

Oto 6 etapów ułatwiających zaczęcie pracy z C#

  1. Wymagania minimalne
  2. Pobierz .Net SDK
  3. Włącz wyróżnienie składni kolorem
  4. Dodaj kompilator C# jako narzędzie programu TextPad
  5. Dodaj filtr dla plików C# dla okna dialogowego Otwórz
  6. Przetestuj czy wszystko działa prawidłowo
Wskazówki dla użytkowników C#:
  1. Uruchamianie aplikacji WinForms

1. Wymagania minimalne

Po pierwsze sprawdź, czy twój system jest odpowiedni dla kompilatora C#. Wymagania minimalne:

  • Microsoft Windows 2000
  • Microsoft Internet Explorer 5.5
początek
2. Pobierz .Net SDK

Następnie musisz pobrać .NET SDK ze strony:

http://www.microsoft.com/net/

Uwaga, plik instalacyjny ma 86 MB! Po zakończeniu pobierania dokonaj instalacji.

początek
3. Włącz wyróżnienie składni kolorem

Aby wyróżniać składnię plików C#, musisz mieć plik defniujący składnię: CSHARP.SYN. Jest on dołączony do TextPada i może być pobrany ze strony http://www.textpad.com/add-ons/syna2g.html. Postępuj zgodnie z instrukcjami instalacji u dołu strony, a więc:

  1. Wybierz z menu Konfiguracja Nowa klasa dokumentu. Pojawi się Kreator klas dokumentów.
  2. W polu Nazwa klasy dokumentu, wpisz C# i kliknij przycisk Dalej.
  3. W polu Typy plików klasy, wpisz *.cs i kliknij Dalej.
  4. Zaznacz wyróżniaj elementy składni kolorem. (?)
  5. Wybierz "csharp.syn" z listy rozwijanej i kliknij Dalej.
  6. Kliknij Zakończ.
początek
4. Dodaj kompilator C# jako narzędzie programu TextPad
  1. Wybierz Preferencje z menu Konfiguracja. Zobaczysz okno dialogowe Preferencje.
  2. Wybierz "Narzędzia".
  3. Kliknij Dodaj i wybierz opcję "Program".
  4. Znajdź CSC.EXE. Powinien się znajdować w podkatalogu głównego katalogu instalacyjnego Windows 2000 o nazwie "ComPlus\v2000.14.1812"
  5. W razie konieczności zmień nazwę narzędzia klikając dwa razy, wolniej niż przy podwójnym kliknięciu, i wpisz nową nazwę C#;. Wstaw "&" przed literą, która będzie służyła do wybierania polecenia menu za pomocą klawiatury.
  6. W razie konieczności kliknij strzałkę w górę by przenieść nowe narzędzie do odpowiedniej pozycji w menu.
  7. Kliknij przycisk OK.
początek
5. Dodaj filtr dla plików C# dla okna dialogowego Otwórz
  1. Wybierz Preferencje z menu Konfiguracja. Zobaczysz okno dialogowe Preferencje.
  2. Zaznacz "Filtrowanie plików".
  3. Kliknij Nowy.
  4. Zmień opis na C#.
  5. Wpisz *.cs w polu znaki wieloznacznie.
  6. W razie potrzeby, kliknij Przesuń w górę, aby przestawić filtr do właściwej pozycji.
  7. Kliknij przycisk OK.

początek


6. Sprawdź, czy wszystko działa prawidłowo.

Nie ma sensu zaczynać czegoś skomplikowanego, na tym etapie spróbuj od "Hello World":

  1. Z menu Plik, wybierz Otwórz i ustaw Pliki typu na C#.
  2. Znajdź Hello.cs w NGWSSDK\Samples\Deployment\1_HelloWorld, i kliknij Otwórz.
  3. Sprawdź, czy komentarze wyświetlane są w kolorze zielonym a słowa kluczowe czerwonym.
  4. W menu Narzędzia wybierz C#.
  5. Sprawdź, czy okno Rezultat polecenia pokazuje "Narzędzie zakończyło działanie z powodzeniem", po czym zamknij to okno.
  6. W menu Narzędzia wybierz Uruchom. Pojawi się okno dialogowe Uruchom.
  7. W polu Polecenie, wpisz Hello.exe i kliknij OK.
  8. Upewnij się, że otworzyło się okno konsoli wyświetlające napis "Hello World using C#!".
  9. Zamknij okno konsoli.

I to wszystko!

początek

Wskazówki dla użytkowników C#:

1. Uruchamianie aplikacji WinForms:

Wskazówiki Ralpha Lecketta:

Aby uruchomić aplikacje WinForms, używam polecenia Narzędzia->Uruchom z następującym plikiem wynikowym:

Polecenie:C:\WINNT\ComPlus\v2000.14.1812\csc.exe
Parametry: @build.rsp
Rozpocznij w:Twój katalog źródeł C#
Przechwyć rezultat: Zaznaczony.
Plik build.rsp zawiera:
#response file
/r:system.dll
/r:system.io.dll
/r:system.drawing.dll
/r:system.winforms.dll
/r:microsoft.win32.interop.dll
/t:winexe
/unsafe
/debug+
MojProgram.cs
początek